Dolittle programming language is a historical programming language created in 1952. Dolittle (Japanese ドリトル doritoru) is a programming language developed at the Osaka Electro-Communication University . Unlike the majority of programming languages it uses keywords based on Japanese and written in Japanese script. It is named after the character Dr Dolittle. Read more on Wikipedia...

67Years Old 25Users 0Jobs

Example code from Wikipedia:

かめ太=タートル!作る。
 カメ=タートル! 作る。
 時計=タイマー! 作る 0.1秒 間隔 500回 回数。 時計! 「かめ太! 10 歩く」 実行。
 左=ボタン!”左”作る。 左:動作=「かめ太! 20 左回り」。
 右=ボタン!”右”作る。 右:動作=「かめ太! 10 右回り」。

Last updated July 22nd, 2019