1C Enterprise Script is an actively used programming language created in 2002. The 1C:Enterprise platform allows for business oriented application development. The software allows work in thick, thin and web clients.[21] It also supports creating mobile applications for Android and iOS in the same environment using the 1C programming language

18Years Old ?Users ?Jobs
  • 1C Enterprise Script first appeared in 2002
  • file extensions for 1C Enterprise Script include bsl and os
  • Have a question about 1C Enterprise Script not answered here? Email me and let me know how I can help.

Example code from Linguist:

Каталог = ОбъединитьПути(ТекущийКаталог(), "libs\oscript-library\src");
Загрузчик_Оригинал_ИмяФайла = ОбъединитьПути(Каталог, "package-loader.os");

Файлы = НайтиФайлы(Каталог, , Ложь);
Для Каждого ВыбФайл Из Файлы Цикл

    Если ВыбФайл.ЭтоФайл() Тогда
        Продолжить;
    КонецЕсли;

    Загрузчик_ИмяФайла = ОбъединитьПути(ВыбФайл.ПолноеИмя, "package-loader.os");
    Загрузчик_Файл = Новый Файл(Загрузчик_ИмяФайла);

    Если Загрузчик_Файл.Существует() Тогда
        Продолжить;
    КонецЕсли;

    КопироватьФайл(Загрузчик_Оригинал_ИмяФайла, Загрузчик_ИмяФайла);

КонецЦикла;

Trending Repos

repo stars description

Last updated February 18th, 2020

Edit 1C Enterprise Script on GitHub