1C Enterprise Script is an actively used programming language created in 2002.

17Years Old 0Users 0Jobs
  • 1C Enterprise Script does not currently rank in our top 50% of languages
  • 1C Enterprise Script first appeared in 2002
  • file extensions for 1C Enterprise Script include bsl and os
  • I have 26 facts about 1C Enterprise Script. what would you like to know? email me and let me know how I can help.

Example code from Linguist:

Каталог = ОбъединитьПути(ТекущийКаталог(), "libs\oscript-library\src");
Загрузчик_Оригинал_ИмяФайла = ОбъединитьПути(Каталог, "package-loader.os");

Файлы = НайтиФайлы(Каталог, , Ложь);
Для Каждого ВыбФайл Из Файлы Цикл

    Если ВыбФайл.ЭтоФайл() Тогда
        Продолжить;
    КонецЕсли;

    Загрузчик_ИмяФайла = ОбъединитьПути(ВыбФайл.ПолноеИмя, "package-loader.os");
    Загрузчик_Файл = Новый Файл(Загрузчик_ИмяФайла);

    Если Загрузчик_Файл.Существует() Тогда
        Продолжить;
    КонецЕсли;

    КопироватьФайл(Загрузчик_Оригинал_ИмяФайла, Загрузчик_ИмяФайла);

КонецЦикла;

Trending Repos

repo stars description

Last updated October 14th, 2019