1C Enterprise Script is an actively used programming language created in 2002.

17Years Old 1,000Users 0Jobs
  • 1C Enterprise Script ranks in the bottom 50% of languages
  • 1C Enterprise Script first appeared in 2002
  • I have 24 facts about 1C Enterprise Script. just email me if you need more.

Example code from Linguist:

Каталог = ОбъединитьПути(ТекущийКаталог(), "libs\oscript-library\src");
Загрузчик_Оригинал_ИмяФайла = ОбъединитьПути(Каталог, "package-loader.os");

Файлы = НайтиФайлы(Каталог, , Ложь);
Для Каждого ВыбФайл Из Файлы Цикл

    Если ВыбФайл.ЭтоФайл() Тогда
        Продолжить;
    КонецЕсли;

    Загрузчик_ИмяФайла = ОбъединитьПути(ВыбФайл.ПолноеИмя, "package-loader.os");
    Загрузчик_Файл = Новый Файл(Загрузчик_ИмяФайла);

    Если Загрузчик_Файл.Существует() Тогда
        Продолжить;
    КонецЕсли;

    КопироватьФайл(Загрузчик_Оригинал_ИмяФайла, Загрузчик_ИмяФайла);

КонецЦикла;
Edit

Last updated February 11th, 2019